Skip Ribbon Commands
Skip to main content

Quick Launch

Todd Klindt's home page > Todd Klindt's SharePoint Admin Blog > Posts > December 2012 Hotfix for SharePoint 2013 breaks MySite Creation
January 03
December 2012 Hotfix for SharePoint 2013 breaks MySite Creation

(See the solution for this issue at the end of this blog post)

Don’t you hate it when a hero lets you down? Like when Nicolas Cage decided to star in Ghost Rider. Twice! That’s how it goes sometimes. Unfortunately that’s how it went with the December 2012 Hotfix for SharePoint 2013. After you install this patch on SharePoint Server 2013 users can no longer create MySites. Existing MySites still work, but no more can be created. When users try to create a MySite you’ll find an error like this in your ULS logs:

01/03/2013 00:32:34.59  OWSTIMER.EXE (0x05F0)              0x0C1C SharePoint Portal Server              Administration  5187                Critical   My Site creation failure for user 'CONTOSO\user1'for site url 'http://my.contoso.com/personal/user1'. The exception was: System.MissingMethodException: Method not found: 'Microsoft.SharePoint.SPSite Microsoft.SharePoint.SPSite.SelfServiceCreateSite(System.String, System.String, System.String, UInt32, Int32, Int32, System.String, System.String, System.String, System.String, System.String, System.String, System.String, System.String, Microsoft.SharePoint.SPSiteSubscription)'.     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.<RunWithElevatedPrivileges>b__3()     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)     at Microsoft.Office.Server.UserProfiles.UserProfile.CreateSite(String strRequestUrl, Boolean bCollision, Int32 overrideCompatLevel, Int32 lcid).             2611f19b-b123-1001-13a4-5ae2bd6a86be

The key to the problem is highlighted, the User Profile Service is trying to create the MySite with a method that doesn’t exist. It looks like regular Self Service Site Creation still works. Full notes on this patch can be found on my SharePoint 2013 Builds wiki.

There’s no way to uninstall SharePoint patches, so if you’ve installed this patch you’re stuck with it. Hopefully this will be fixed in the next CU or Hotfix.

You can keep up with all the SharePoint 2013 Patches by visiting my SharePoint 2013 Builds page and following SharePoint2013Patches on Twitter.

I’d like to thank Ali Salih and Jason Himmelstein Blog | Twitter) for bringing this to my attention and Trevor Seward (Blog | Twitter) for helping me reproduce and troubleshoot it.

Edited to add:

This problem can be fixed with the installation of another December 2012 Hotfix, KB2752001.

tk

ShortURL: http://www.toddklindt.com/SP2013December2012HotfixRegression

Edited 1/25/2013

Comments

Hi Todd

Hi Todd,

I got this update on my demo environment and I tried to reproduce this error.

I created a new user in my active directory, the User Profile SA  picked it up in 5 minutes and created the My Site. (It's at "almost ready" atm)

My Config Database version is at this level:  15.0.4433.1506.

Can you please give me more details on how to reproduce it?

Thank you very much!

Vlad Catrinescu
www.absolute-sharepoint.com
vladcatrinescu@hotmail.com
 on 1/7/2013 10:57 AM

Share the fix

Hi,

Any details on the fix that you are able to share?

Regards,

Chuck
 on 1/23/2013 7:59 AM

Re: Share the fix

Hi Chuck,
I don't know of a fix. Once I find one, I'll edit this blog post to include it.

tk
Todd O. KlindtNo presence information on 1/23/2013 3:53 PM

Re: Hi Todd

Vlad,
Thanks for the followup. I'm not sure why you aren't seeing the same problem.

tk
Todd O. KlindtNo presence information on 1/23/2013 3:55 PM

Re: December 2012 Hotfix for SharePoint 2013 breaks MySite Creation

In my case
This error occurs on Windows Server 2008 R2


First step: Install Service Pack 1 for Windows Server 2008 R2

Second:
The solution is one of the following updates (i have installed both, so I can’t told you which one it is):
http://support.microsoft.com/kb/2752001
http://support.microsoft.com/kb/2554876

Third:
Start Request Management service from Central Administration -> System Settings -> Manage Services on server
 on 1/25/2013 8:43 AM

Re: December 2012 Hotfix for SharePoint 2013 breaks MySite Creation

Yup, that's the fix. I was updated this very blog post when you left that comment. :)

tk
Todd O. KlindtNo presence information on 1/25/2013 8:52 AM

Re: December 2012 Hotfix for SharePoint 2013 breaks MySite Creation

Great, Thank you very much

Those steps solved my Problem

Best regards
Andreas
 on 1/25/2013 9:51 AM

Re: December 2012 Hotfix for SharePoint 2013 breaks MySite Creation

hi Todd,

i have met the same problem, but my inner exception is "Access is Denied". The user who run the code is not the system account.
 on 3/6/2013 6:52 AM

Add Comment

Items on this list require content approval. Your submission will not appear in public views until approved by someone with proper rights. More information on content approval.

Title


Body *


Today's date *

Select a date from the calendar.
Please enter today's date so I know you are a real person

Twitter


Want a message when I reply to your comment? Put your Twitter handle here.

Attachments

 

 Please Support my Sponsors